Hello from Germany!

General discussion forum. Moderated. Keep it clean and nice folks.
Otto Skorzeny
Posts: 955
Joined: Fri Feb 28, 2014 12:41 pm
TOA Membership Number: 0
Years Owned: 1966 Toronado

Re: Hello from Germany!

Postby Otto Skorzeny » Sun May 20, 2018 5:19 am

Is there any company near you in Germany that can straighten the front bumper?

Otto Skorzeny
Posts: 955
Joined: Fri Feb 28, 2014 12:41 pm
TOA Membership Number: 0
Years Owned: 1966 Toronado

Re: Hello from Germany!

Postby Otto Skorzeny » Sun May 20, 2018 5:26 am

When I was at the vintage auto races at Road Atlanta, some guy took a bunch of photos of me driving around and put them on a website. A friend of mine just came across them by accident. The author obviously didn't know anything about Toronados but his pictures are good.

http://www.car-revs-daily.com/2014/05/0 ... er-purple/

Mikel
Posts: 118
Joined: Tue Aug 11, 2009 7:26 am
TOA Membership Number: 100
Location: New Haven, CT

Re: Hello from Germany!

Postby Mikel » Sun May 20, 2018 7:35 am

Otto Skorzeny wrote:When I was at the vintage auto races at Road Atlanta, some guy took a bunch of photos of me driving around and put them on a website. A friend of mine just came across them by accident. The author obviously didn't know anything about Toronados but his pictures are good.

http://www.car-revs-daily.com/2014/05/0 ... er-purple/


Yes, the text shows that he's never driven an early Toronado. My '66 is a surprisingly nimble car that will go through twisty roads quicker than I would want to go.

Otto Skorzeny
Posts: 955
Joined: Fri Feb 28, 2014 12:41 pm
TOA Membership Number: 0
Years Owned: 1966 Toronado

Re: Hello from Germany!

Postby Otto Skorzeny » Sun May 20, 2018 12:36 pm

Of course. Front end heavy? No. GM got the balance almost perfect with 55% of the weight up front and 45% in the rear. No torque steer or oversteer, either.

bcroe
Posts: 191
Joined: Thu Nov 15, 2012 12:25 pm
TOA Membership Number: 378
Years Owned: 79 Toronado or Eldorado

Hello from Germany!

Postby bcroe » Sun May 20, 2018 7:40 pm

Jelonek wrote: today a one question to transmission : which one do i
have , is that TH 425 or th400 ?? Toronado ist from 1966..


In addition, the 66-67 TH425s were switch pitch. You may note the 2 wires
going up to a mechanical switch on the throttle linkage. A few have been converted
to an electronic control, then you will find the upper trans lug wire going to a control
box. Whatever type you have, you should run the test for solenoid clicks from the
trans, with just the ignition on. It impacts driving. Bruce Roe

Jelonek
Posts: 95
Joined: Mon Nov 13, 2017 11:59 am
TOA Membership Number: 0
Years Owned: 1

Re: Hello from Germany!

Postby Jelonek » Mon May 21, 2018 1:48 am

thanks for informations about the transmision :?: Bruce

Otto......with my bumper.. hm if... than i have to do it couse there is no a corporation and this is no coplicated (I hope) :?

Jelonek
Posts: 95
Joined: Mon Nov 13, 2017 11:59 am
TOA Membership Number: 0
Years Owned: 1

Re: Hello from Germany!

Postby Jelonek » Sun Jul 01, 2018 7:16 am

another reason for the driving with the Toronado :D
Attachments
c3.jpg
c3.jpg (126.71 KiB) Viewed 802 times
B2.jpg
B2.jpg (110.36 KiB) Viewed 802 times
A1.jpg
A1.jpg (141.82 KiB) Viewed 802 times

Jelonek
Posts: 95
Joined: Mon Nov 13, 2017 11:59 am
TOA Membership Number: 0
Years Owned: 1

Re: Hello from Germany!

Postby Jelonek » Tue Jul 03, 2018 9:41 am


mindreader45
Posts: 4
Joined: Tue Jul 17, 2018 4:03 am
TOA Membership Number: 0

Re: Hello from Germany!

Postby mindreader45 » Wed Jul 18, 2018 6:36 am

Jelonek wrote:another reason for the driving with the Toronado :D


As a Bridal car? Nice.

Jelonek
Posts: 95
Joined: Mon Nov 13, 2017 11:59 am
TOA Membership Number: 0
Years Owned: 1

Re: Hello from Germany!

Postby Jelonek » Thu Aug 30, 2018 4:57 am

Hi guys
I have a small Problem with my Toro :evil:
yersterday I didn´t know that the engine works (becouse of phone !!! and noise :? ) and I turn on the key - hotstart :evil:
after that I cann´t start the engine again, I tryed oly one time .., now I have only a very bad niose from the starter and every cable from the battery are during the start hot.
do you know this "Problem" ?
and how do you think ... what ist wrong.... complittely starter or only magneting coupling?

thank´s

Wojtek


Return to “General Talk”

Who is online

Users browsing this forum: No registered users and 0 guests